Настройка cisco 871

Как “запустить” коммутатор Cisco 871. Данные настройки применимы для всех коммутаторов cisco этой серии коммутаторов.

Особенности настройки cisco 871

 

Cisco ISR 871

Рис.1 Схематическое изображение аршрутизатора Cisco ISR 871.

У маршрутизатора ISR 871 есть встроенный коммутатор на 4 порта (fa0-fa3) и 1 интерфейс 3го уровня (fa4).

Настройки 3го уровня, например, задание IP-адреса, для портов fa0-fa3 применяются к интерфейсу vlan 1. Также возможно создать несколько vlan и назначить их на порты fa0-fa3. Таким образом, на каждом порту может быть свой ip адрес.

Пример задачи для настройки Cisco ISR 871

Клиенты из локальной сети должны получать адреса по DHCP и иметь возможность выходить в Интернет.

На маршрутизаторе необходимо настроить:

  • NAT
    • Адрес на внешнем интерфейсе (fa4) выдается динамически
    • Транслироваться должны любые адреса из локальной сети
    • Брандмауэр ip inspect
  • DHCP-сервер
    • Сервер должен выдавать адреса из диапазона 192.168.1.211-192.168.1.254
    • Выдавать адрес маршрута по умолчанию и DNS-сервера

 

 Конфигурация маршрутизатора Cisco ISR 871

!
version 12.4
!
hostname Router
!
!
ip subnet-zero
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.1.1 192.168.1.210
!
ip dhcp pool LOCAL
   network 192.168.1.0 255.255.255.0
   dns-server 62.80.160.130 193.193.193.100 
   default-router 192.168.1.100 
!
!
ip inspect name Internet http timeout 3600
ip inspect name Internet icmp
ip inspect name Internet ftp timeout 3600
ip inspect name Internet tcp timeout 3600
ip inspect name Internet h323 timeout 3600
ip inspect name Internet smtp timeout 3600
ip inspect name Internet udp timeout 15
!
!
crypto pki trustpoint TP-self-signed-2657071675
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-2657071675
 revocation-check none
 rsakeypair TP-self-signed-2657071675
!
!
crypto pki certificate chain TP-self-signed-2657071675
 certificate self-signed 01 nvram:IOS-Self-Sig#3503.cer
username Admin privilege 15 password 0 p@$$w0rd
!
! 
!
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
 ip address dhcp
 ip nat outside
 ip inspect Internet out
 ip virtual-reassembly
 duplex auto
 speed auto
!
interface Vlan1
 ip address 192.168.1.100 255.255.255.0
 ip nat inside
 ip virtual-reassembly
!
ip classless
!
ip http server
ip http authentication local
ip http secure-server
ip nat inside source list 1 interface FastEthernet4 overload
!
access-list 1 permit 192.168.1.0 0.0.0.255
!

 

 

Связанные элементы